VM Provisioning Unavailable

Incident Report for Cudo Compute

Resolved

Dear valued customers,

We confirm the issue was resolved, and the service has resumed normal operation. We hope that you can continue your projects on CUDO Compute.
If you continue to experience issues deploying VMs, please contact our support team via Help -> Submit a support ticket.

Kind regards,
CUDO Compute Support
Posted Oct 24, 2025 - 10:12 UTC

Investigating

We are investigating an issue that is preventing the creation of new Virtual Machines (VMs). Any attempt to create a new VM is currently failing, with the status incorrectly showing as 'Unknown'.

All existing VMs are operating normally and are unaffected by this incident.

Our engineering team is actively working to resolve this provisioning issue and restore the ability to create new VMs as quickly as possible. We apologize for the disruption.

We will post an update as soon as we have more information.
Posted Oct 24, 2025 - 00:00 UTC
This incident affected: Compute (Core Services, Web UI).