Recurring Incident: User Login Instability due to Cloudflare Outage

Incident Report for Cudo Compute

Resolved

Cloudflare have resolved the issue that was affecting our authentication services on CUDO Compute.

Service has now been restored, and users are able to log in and authenticate on the CUDO Compute portal.

Thank you to all of our users for their patience whilst this third-party issue was resolved.
Posted Nov 19, 2025 - 12:20 UTC

Update

Cloudflare have identified an issue and are implementing a fix.

Via https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 13:10 UTC

Identified

We are observing a recurrence of the login issues affecting the Cudo Compute platform. Despite the previous recovery, our upstream provider (Cloudflare) is experiencing renewed instability which is once again impacting our authentication services.

We have reopened this incident and are monitoring the provider's status. We apologize for the frustration caused by this intermittent service availability.
Posted Nov 18, 2025 - 12:48 UTC
This incident affected: Compute (Authentication Services).