Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 02, 2025 - 08:30 UTC
Scheduled
Dear customers,
We would like to inform you of a planned maintenance activity at no-kristiansand-1 data centre. Please find details of this maintenance below:
Start date: 02/12/2025 08:30 AM BST/08:30 UTC End date: 02/12/2025 3:00 PM BST/15:00 UTC
Affected data centres: no-kristiansand-1
Event Type: Generator Power Supply Redundancy Test
Description: The data centre team will perform power cuts to ensure the system switches to the back-up generators in case a real power cut occurs.
Risk: Low. The back-up generators are expected to replace the main power feed.
Action required: While this is maintenance is not service-impacting, we advise all users to ensure a backup of their virtual machines and data is taken prior to the maintenance window and on a regular basis.
We apologise for any disruptions and appreciate your understanding. If you have issues or concerns regarding the activity, please contact our support team by registering a support ticket via the form on the Cudo Compute console.
Posted Nov 25, 2025 - 15:01 UTC
This scheduled maintenance affected: Data centres (no-kristiansand-1).