Cloudflare has implemented a fix for their global outage, and we have verified that authentication services for Cudo Compute are fully functional. Users can now log in to the platform without issues.
We will continue to monitor the stability of the connection over the next hour to ensure no residual impact. Thank you for your patience.
Posted Nov 18, 2025 - 12:10 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:03 UTC
Investigating
We are currently experiencing issues with user logins on the Cudo Compute platform. This is due to an ongoing major outage with our upstream provider, Cloudflare, which is impacting our authentication services.
Users may encounter timeouts or network errors when attempting to access the console. Our team is monitoring the situation closely and is ready to restore full access as soon as Cloudflare implements a fix.
Posted Nov 18, 2025 - 12:02 UTC
This incident affected: Compute (Core Services, Web UI, Authentication Services).